The Windows SDK version 10.0.15063.0 was not found [ Nvidia Cuda GPU Sample Code Compilation]

I get the below error message snippet a lot while trying to compile Nvidia Cuda 10 samples for testing Cuda GPU development [ c++ code]:

The Windows SDK version 10.0.15063.0 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting “Retarget solution”.
145>Done building project “topologyQuery_vs2017.vcxproj” — FAILED.

Solution l have found is to double check the Visual Studio 2017 installer and check installing below. It seems even though l have a full VS 2017 installation with all the default sections installed, a more recent SDK is installed on my workstation.

I run Windows 10 Home together with Visual Studio 2017 Enterprise Edition, and have Nvidia Cuda 10 installed for GPU programming.

After doing above, l was able to successfully compile most of the Cuda Code samples as shown below, without the previous error. Yes!!

Microsoft HoloLens VR Test Notes

Below are screenshots as l try/test a small “hello world” project first created using Unity, then compiled for using Microsoft HoloLens using Microsoft Visual Studio.

I used:


Above is the current spot l am stuck on, working on getting that resolved.

 

Render SSRS 2008 Report from Website to Adobe PDF

This is a test project to see if l can successfully render to PDF from an asp.net website, using Report Control from a Visual Studio 2008 project.
First l created a simple sample table called MyContact from some files from the AdventureWorks database. Heres the code:

SELECT
    [ContactID]      ,[Title]      ,[FirstName]      ,[LastName]
      ,[EmailAddress]      ,[Phone]      ,[ModifiedDate]
      into MyContacts
  FROM [AdventureWorks].[Person].[Contact]
GO

If you wish to create the table directly, heres the code:

USE [AdventureWorks]
GO
/****** Object:  Table [dbo].[MyContacts]    Script Date: 01/15/2009 22:34:31 ******/
SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
CREATE TABLE [dbo].[MyContacts](
 [ContactID] [int] IDENTITY(1,1) NOT NULL,
 [Title] [nvarchar](8) NULL,
 [FirstName] [dbo].[Name] NOT NULL,
 [LastName] [dbo].[Name] NOT NULL,
 [EmailAddress] [nvarchar](50) NULL,
 [Phone] [dbo].[Phone] NULL,
 [ModifiedDate] [datetime] NOT NULL
) ON [PRIMARY]
GO

I’ll attach a link to a text file with data for populating this with over 19,000 rows, as well as a link to the entire source code.
Heres a link to the Report Webpage. (should be active soon)
Currently l’m trying to debug the error below:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly ‘Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’ or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 53:     <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
Line 54:     <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
Line 55:     <add assembly="Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
Line 56:     <add assembly="Microsoft.ReportViewer.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
Line 57:    </assemblies>

 

 

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLMSoftwareMicrosoftFusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLMSoftwareMicrosoftFusion!EnableLog].

This seems to be a possible solution to this problem.